Home / Software / Tips and Tricks / Requires stdole Version 7.0.33 be installed in GAC ClickOnce deployment

Requires stdole Version 7.0.33 be installed in GAC ClickOnce deployment

Updated:  05/14/2009 07:05 AM
Author:  Shiju Mathews

Status:    Resolved.


This is because the application can’t find the dll in GAC when the deployment detected it as a prerequisite.
May be your application is using MS Office or some third party application. Try to install this on the box.


Also try
Go to the 'Publish' tab in the visual studio project properties
selecting the 'Application Files' button.


Then selected the options:
'File Name' of 'stdole.dll'
'Publish status' to 'Include' and
'Download Group' to 'Required'.


Re-publish the application.
Try to deploy the application